summaryrefslogtreecommitdiff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-03-11 10:56:07 +0100
committerStef Walter <stefw@gnome.org>2013-03-12 09:31:36 +0100
commitdf29c0dcb6cce6a215dee9dc4e17aff59ae67c5b (patch)
treeaf7cadbef8f1dd4390c729d7493e7bfd02940d15 /doc/manual/Makefile.am
parent0a6bf1bfad01aae0b707b9e13e6d14deade9cecf (diff)
downloadp11-kit-df29c0dcb6cce6a215dee9dc4e17aff59ae67c5b.tar.gz
doc: Move manual into doc/manual subdirectory
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am132
1 files changed, 132 insertions, 0 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
new file mode 100644
index 0000000..59c8624
--- /dev/null
+++ b/doc/manual/Makefile.am
@@ -0,0 +1,132 @@
+abs_top_builddir = @abs_top_builddir@
+
+NULL =
+
+# We require automake 1.6 at least.
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module, e.g. 'glib'.
+DOC_MODULE=p11-kit
+
+# The top-level SGML file. You can change this if you want to.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting the functions and macros.
+# e.g. DOC_SOURCE_DIR=../../../gtk
+DOC_SOURCE_DIR=../../p11-kit
+
+# Extra options to pass to gtkdoc-scangobj. Not normally needed.
+SCANGOBJ_OPTIONS= --version
+
+# Extra options to supply to gtkdoc-scan.
+# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
+SCAN_OPTIONS= --rebuild-types --deprecated-guards="P11_KIT_DISABLE_DEPRECATED"
+
+# Extra options to supply to gtkdoc-mkdb.
+# e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-mktmpl
+# e.g. MKTMPL_OPTIONS=--only-section-tmpl
+MKTMPL_OPTIONS=
+
+# Extra options to supply to gtkdoc-fixref. Not normally needed.
+# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
+FIXXREF_OPTIONS=
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
+# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
+HFILE_GLOB=$(top_srcdir)/p11-kit/*.h
+CFILE_GLOB=$(top_srcdir)/p11-kit/*.c
+
+# Header files to ignore when scanning.
+# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
+IGNORE_HFILES= \
+ private.h \
+ pkcs11.h \
+ conf.h \
+ debug.h \
+ dict.h \
+ mock-module.h \
+ pkcs11.h \
+ pkcs11x.h \
+ private.h \
+ util.h \
+ array.h \
+ compat.h \
+ mock-module.h
+
+# Images to copy into HTML directory.
+# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
+HTML_IMAGES=
+
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
+# e.g. content_files=running.sgml building.sgml changes-2.0.sgml
+content_files=p11-kit-config.xml p11-kit-sharing.xml \
+ p11-kit-devel.xml \
+ p11-kit-trust.xml \
+ p11-kit.xml \
+ annotation-glossary.xml \
+ $(NULL)
+
+# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
+# These files must be listed here *and* in content_files
+# e.g. expand_content_files=running.sgml
+expand_content_files=
+
+# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
+# Only needed if you are using gtkdoc-scangobj to dynamically query widget
+# signals and properties.
+# e.g. INCLUDES=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
+# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
+INCLUDES=
+GTKDOC_LIBS=
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+if ENABLE_GTK_DOC
+man8_MANS = p11-kit.8
+man5_MANS = pkcs11.conf.5
+
+XSLTPROC_FLAGS = \
+ --nonet \
+ --stringparam man.output.quietly 1 \
+ --stringparam funcsynopsis.style ansi \
+ --stringparam man.th.extra1.suppress 1 \
+ --stringparam man.authors.section.enabled 0 \
+ --stringparam man.copyright.section.enabled 0
+
+XSLTPROC_MAN = \
+ $(XSLTPROC) $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+
+.xml.5:
+ $(AM_V_GEN) $(XSLTPROC_MAN) $<
+.xml.8:
+ $(AM_V_GEN) $(XSLTPROC_MAN) $<
+
+else # ENABLE_GTK_DOC
+
+man5_MANS =
+man8_MANS =
+
+endif # ENABLE_GTK_DOC
+
+MAN_IN_FILES = \
+ $(man8_MANS:.8=.xml) \
+ $(man5_MANS:.5=.xml) \
+ $(NULL)
+
+CLEANFILES += \
+ $(man5_MANS) \
+ $(man8_MANS) \
+ $(NULL)
+
+EXTRA_DIST += \
+ $(MAN_IN_FILES) \
+ version.xml.in \
+ version.xml \
+ $(NULL)