summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-02-06 21:57:45 +0100
committerStef Walter <stefw@gnome.org>2013-05-21 10:47:51 +0200
commit5c19f0cf66495f00ccf69eba1d0915f862a88c8d (patch)
treee8ae733062507a0a4cc5c134d1fdd62cf055cddd /p11-kit/Makefile.am
parentff853bd7902e271256cada4a1b20a3d46b519b69 (diff)
downloadp11-kit-5c19f0cf66495f00ccf69eba1d0915f862a88c8d.tar.gz
p11-kit: Managed PKCS#11 module loading
Support a new managed style module loading for PKCS#11 modules. This allows us to better coordinate between multiple callers of the same PKCS#11 modules and provide hooks into their behavior. This meant redoing the public facing API. The old methods are now deprecated, marked and documented as such.
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 027b7c8..d7e1694 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -14,6 +14,7 @@ INCLUDES = \
incdir = $(includedir)/p11-kit-1/p11-kit
inc_HEADERS = \
+ deprecated.h \
iter.h \
p11-kit.h \
pin.h \
@@ -24,7 +25,7 @@ MODULE_SRCS = \
util.c \
conf.c conf.h \
iter.c \
- modules.c \
+ modules.c modules.h \
pkcs11.h \
pin.c \
pkcs11.h \
@@ -103,7 +104,9 @@ example_DATA = pkcs11.conf.example
EXTRA_DIST = \
p11-kit-1.pc.in \
- pkcs11.conf.example.in
+ pkcs11.conf.example.in \
+ docs.h \
+ $(NULL)
# Proxy module is actually same as library, so install a link
install-exec-hook: