summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-09-19 09:24:35 +0200
committerStef Walter <stefw@collabora.co.uk>2011-09-19 09:24:35 +0200
commita081b6652acc9d9a9af22a266f9175f689b8c5d1 (patch)
tree51f7d06580542d901800a6e5eefa691f7c5d631c /p11-kit/Makefile.am
parent8054865325fdb2221f3e425d04d9e03f6475553e (diff)
downloadp11-kit-a081b6652acc9d9a9af22a266f9175f689b8c5d1.tar.gz
Expand the libdir path correctly
https://bugs.freedesktop.org/show_bug.cgi?id=40985
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index dc9f8ab..26a03b1 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -1,7 +1,14 @@
+NULL =
INCLUDES = \
-I$(top_srcdir) \
- -DP11_KIT_FUTURE_UNSTABLE_API
+ -DP11_KIT_FUTURE_UNSTABLE_API \
+ -DP11_SYSTEM_CONFIG_FILE=\""$(p11_system_config_file)"\" \
+ -DP11_SYSTEM_CONFIG_MODULES=\""$(p11_system_config_modules)"\" \
+ -DP11_USER_CONFIG_FILE=\""$(p11_user_config_file)"\" \
+ -DP11_USER_CONFIG_MODULES=\""$p11_user_config_modules"\" \
+ -DP11_MODULE_PATH=\""$p11_module_path"\" \
+ $(NULL)
incdir = $(includedir)/p11-kit-1/p11-kit