summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-08-23 15:34:04 +0200
committerStef Walter <stef@thewalter.net>2014-07-08 08:57:30 +0200
commitc785ab66890ad7b73c556d6afdf2bb8a32dd50e2 (patch)
treeb871dc6edf5e0a094fa3736eccdb92ca2a7091a8 /p11-kit/Makefile.am
parent469e75bb8184392cb47b3cb4897589caabe56e70 (diff)
downloadp11-kit-c785ab66890ad7b73c556d6afdf2bb8a32dd50e2.tar.gz
rpc: Implement PKCS#11 messages/client/server code
* This enables passing around bytes which represent PKCS#11 RPC calls. * Caller is responsible for connecting/disconnecting and so on. * Client side caller gets a mixin from p11_rpc_client_init() to call into, which generates callbacks with byte arrays to be transported. * Server side calls p11_rpc_server_handle() with a CK_FUNCTION_LIST_PTR on which relevant methods get called. * Doesn't yet implement the actual daemon or clients etc... https://bugs.freedesktop.org/show_bug.cgi?id=54105
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 92cddfb..da195ac 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -36,6 +36,8 @@ MODULE_SRCS = \
proxy.c proxy.h \
private.h \
messages.c \
+ rpc-message.c rpc-message.h \
+ rpc-client.c rpc-server.c rpc.h \
uri.c \
virtual.c virtual.h \
$(inc_HEADERS)