summaryrefslogtreecommitdiff
path: root/trust/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-24 11:34:47 +0100
committerStef Walter <stefw@gnome.org>2013-02-05 14:54:46 +0100
commit5147d71466455b3d087b3f3a7472a35e8216c55a (patch)
tree4b81eee35b7d0ec877a34c4fde06478d700a3960 /trust/Makefile.am
parent603c7d4eb996f51178ccc9d235597497bbb2c7a4 (diff)
downloadp11-kit-5147d71466455b3d087b3f3a7472a35e8216c55a.tar.gz
Add basic trust module
This is based off the roots-store from gnome-keyring and loads certificates from a root directory and exposes them as PKCS#11 objects.
Diffstat (limited to 'trust/Makefile.am')
-rw-r--r--trust/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/trust/Makefile.am b/trust/Makefile.am
new file mode 100644
index 0000000..413bb51
--- /dev/null
+++ b/trust/Makefile.am
@@ -0,0 +1,52 @@
+NULL =
+
+SUBDIRS = . tests
+
+COMMON = $(top_srcdir)/common
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/common \
+ $(NULL)
+
+MODULE_SRCS = \
+ parser.c parser.h \
+ module.c module.h \
+ session.c session.h \
+ token.c token.h \
+ $(NULL)
+
+configdir = $(p11_package_config_modules)
+config_DATA = p11-kit-trust.module
+
+moduledir = $(p11_module_path)
+module_LTLIBRARIES = \
+ p11-kit-trust.la
+
+p11_kit_trust_la_CFLAGS = \
+ $(LIBTASN1_CFLAGS)
+
+p11_kit_trust_la_LIBADD = \
+ $(top_builddir)/common/libp11-data.la \
+ $(top_builddir)/common/libp11-library.la \
+ $(top_builddir)/common/libp11-compat.la \
+ $(LIBTASN1_LIBS)
+
+p11_kit_trust_la_LDFLAGS = \
+ -no-undefined -module -avoid-version \
+ -version-info $(P11KIT_LT_RELEASE) \
+ -export-symbols-regex 'C_GetFunctionList' \
+ $(NULL)
+
+p11_kit_trust_la_SOURCES = $(MODULE_SRCS)
+
+noinst_LTLIBRARIES = \
+ libtrust-testable.la
+
+libtrust_testable_la_LDFLAGS = \
+ -no-undefined
+
+libtrust_testable_la_SOURCES = $(MODULE_SRCS)
+
+EXTRA_DIST = \
+ p11-kit-trust.module