summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am31
1 files changed, 4 insertions, 27 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index b3e4eaf..2df3915 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -13,6 +13,7 @@ noinst_LTLIBRARIES = \
libp11-common.la \
libp11-library.la \
libp11-test.la \
+ libp11-tool.la \
$(NULL)
libp11_common_la_SOURCES = \
@@ -41,30 +42,6 @@ libp11_test_la_SOURCES = \
test.c test.h \
$(NULL)
-if WITH_ASN1
-
-noinst_LTLIBRARIES += \
- libp11-data.la \
- $(NULL)
-
-libp11_data_la_SOURCES = \
- asn1.c asn1.h \
- basic.asn basic.asn.h \
- base64.c base64.h \
- oid.c oid.h \
- openssl.asn openssl.asn.h \
- pem.c pem.h \
- pkix.asn pkix.asn.h \
- utf8.c utf8.h \
- x509.c x509.h \
- $(NULL)
-
-libp11_data_la_CFLAGS = \
- $(LIBTASN1_CFLAGS)
-
-asn:
- asn1Parser -o pkix.asn.h pkix.asn
- asn1Parser -o openssl.asn.h openssl.asn
- asn1Parser -o basic.asn.h basic.asn
-
-endif # WITH_ASN1
+libp11_tool_la_SOURCES = \
+ tool.c tool.h \
+ $(NULL) \ No newline at end of file