summaryrefslogtreecommitdiff
path: root/common/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/tests/Makefile.am')
-rw-r--r--common/tests/Makefile.am32
1 files changed, 1 insertions, 31 deletions
diff --git a/common/tests/Makefile.am b/common/tests/Makefile.am
index 942bc12..637399b 100644
--- a/common/tests/Makefile.am
+++ b/common/tests/Makefile.am
@@ -22,42 +22,12 @@ CHECK_PROGS = \
test-buffer \
test-url \
test-path \
+ test-lexer \
$(NULL)
noinst_PROGRAMS = \
$(CHECK_PROGS)
-if WITH_ASN1
-
-LDADD += \
- $(top_builddir)/common/libp11-data.la \
- $(LIBTASN1_LIBS) \
- $(NULL)
-
-AM_CPPFLAGS += \
- $(LIBTASN1_CFLAGS) \
- $(NULL)
-
-CHECK_PROGS += \
- test-asn1 \
- test-base64 \
- test-lexer \
- test-pem \
- test-oid \
- test-utf8 \
- test-x509 \
- $(NULL)
-
-noinst_PROGRAMS += \
- frob-cert \
- frob-ku \
- frob-eku \
- frob-cert \
- frob-oid \
- $(NULL)
-
-endif # WITH_ASN1
-
TESTS = $(CHECK_PROGS)
LDADD += \