summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am30
1 files changed, 10 insertions, 20 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 430b89e..a7796e8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,32 +6,21 @@ INCLUDES = \
-DSRCDIR=\"$(srcdir)\" \
-DP11_KIT_FUTURE_UNSTABLE_API
+LDADD = \
+ $(top_builddir)/p11-kit/libp11-kit-testable.la \
+ $(LTLIBINTL)
+
noinst_PROGRAMS = \
hash-test \
ptr-array-test \
conf-test \
uri-test \
- pin-test
-
-hash_test_LDADD = \
- $(top_builddir)/p11-kit/libp11-kit-testable.la \
- $(LTLIBINTL)
-
-ptr_array_test_LDADD = \
- $(top_builddir)/p11-kit/libp11-kit-testable.la \
- $(LTLIBINTL)
+ pin-test \
+ p11-test
-conf_test_LDADD = \
- $(top_builddir)/p11-kit/libp11-kit-testable.la \
- $(LTLIBINTL)
-
-uri_test_LDADD = \
- $(top_builddir)/p11-kit/libp11-kit-testable.la \
- $(LTLIBINTL)
-
-pin_test_LDADD = \
- $(top_builddir)/p11-kit/libp11-kit-testable.la \
- $(LTLIBINTL)
+p11_test_SOURCES = \
+ p11-test.c \
+ mock-module.c mock-module.h
check-am:
./hash-test
@@ -39,6 +28,7 @@ check-am:
./conf-test
./uri-test
./pin-test
+ ./p11-test
EXTRA_DIST = \
cutest \