summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2021-02-25 16:40:41 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2021-02-25 16:40:41 +0800
commit09bf1b41b40151044644d0e35ba9949007fc83cd (patch)
tree072568a298dab883ea052d7cdff3bcb38eafbfea /meson.build
parent4dfe591823eec1d5f702a909ae9206f5fa5cb47d (diff)
downloadpango-hb-dont-fallback-too-early.tar.gz
build: Don't build HarfBuzz prematurelyhb-dont-fallback-too-early
For Visual Studio builds, since HarfBuzz is built with CMake until HarfBuzz 2.6.x yet we only require HarfBuzz 2.0.0 or later, we aren't able to find pre-2.6.x HarfBuzz using Meson's dependency() method as the support for CMake config files is not done in Meson. As a result, we need to make sure that we first manually look for the HarfBuzz/HarfBuzz-GObject libraries before we attempt to use the fallback mechanism in Meson, so that we won't rebuild HarfBuzz unneccesarily. This rebuild will also cause issues for older compilers that don't have enough support for C++11 as building Harfbuzz with Meson support requires a C++11 compiler, which was mandated in HarfBuzz 2.5.0.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 28d9c9ba..3ebbfeff 100644
--- a/meson.build
+++ b/meson.build
@@ -239,9 +239,7 @@ fontconfig_pc=''
harfbuzz_lib=''
fontconfig_lib=''
-harfbuzz_dep = dependency('harfbuzz', version: harfbuzz_req_version, required: false,
- fallback: ['harfbuzz', 'libharfbuzz_dep'],
- default_options: ['coretext=enabled'])
+harfbuzz_dep = dependency('harfbuzz', version: harfbuzz_req_version, required: false)
if harfbuzz_dep.found()
harfbuzz_pc = 'harfbuzz'
else
@@ -262,7 +260,8 @@ endif
# when finding dependencies via CMake files is fixed.
if not harfbuzz_dep.found()
harfbuzz_dep = dependency('harfbuzz', version: harfbuzz_req_version,
- fallback: ['harfbuzz', 'libharfbuzz_dep'])
+ fallback: ['harfbuzz', 'libharfbuzz_dep'],
+ default_options: ['coretext=enabled'])
endif
if not harfbuzz_dep.found()