summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-01-03 20:52:58 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-01-03 20:58:27 -0500
commit9071cff538290db9dc80ac1da63e37d01a44c5d2 (patch)
tree51f023944a9bf0748ba592e56ae5f464374a9593 /meson.build
parent98dc18209b9c523e267c6c11c2c8b93b88ee3506 (diff)
downloadpango-9071cff538290db9dc80ac1da63e37d01a44c5d2.tar.gz
Enable coretext for the harfbuzz subprojecthb-coretext
On OS X, we need hb_coretext_font_create, so pass coretext=enabled to harfbuzz.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aa537940..5bd193c8 100644
--- a/meson.build
+++ b/meson.build
@@ -239,7 +239,9 @@ fontconfig_pc=''
harfbuzz_lib=''
fontconfig_lib=''
-harfbuzz_dep = dependency('harfbuzz', version: harfbuzz_req_version, required: false)
+harfbuzz_dep = dependency('harfbuzz', version: harfbuzz_req_version, required: false,
+ fallback: ['harfbuzz', 'libharfbuzz_dep'],
+ default_options: ['coretext=enabled'])
if harfbuzz_dep.found()
harfbuzz_pc = 'harfbuzz'
else