summaryrefslogtreecommitdiff
path: root/modules/thai/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2003-05-29 22:02:58 +0000
committerTor Lillqvist <tml@src.gnome.org>2003-05-29 22:02:58 +0000
commit17f905e5da832ed555b5ebd3c5353842bf8b1471 (patch)
tree1dd1a3789f3967ab22d45352c48ac1f334159889 /modules/thai/Makefile.am
parentf74a7de5f5b66832db3102594973e638d5ced4ed (diff)
downloadpango-17f905e5da832ed555b5ebd3c5353842bf8b1471.tar.gz
Add HAVE_X.
2003-05-29 Tor Lillqvist <tml@iki.fi> * acconfig.h: Add HAVE_X. * configure.in: Set HAVE_X. * modules/thai/thai-shaper.h: Don't include pangox.h unless HAVE_X. Also leave out the PangoXSubfont field unless HAVE_X. * modules/hangul/Makefile.am * modules/indic/Makefile.am * modules/thai/Makefile.am: Use -no-undefined on Windows. * modules/thai/thai-shaper.c: Include config.h for HAVE_X. * README.win32: Some minor edits. * pango/pango.def: Add pango_fc_* entries. * pango/pangoft2.def: Add some missing entries.
Diffstat (limited to 'modules/thai/Makefile.am')
-rw-r--r--modules/thai/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/thai/Makefile.am b/modules/thai/Makefile.am
index 82918faf..179c5ffc 100644
--- a/modules/thai/Makefile.am
+++ b/modules/thai/Makefile.am
@@ -13,6 +13,10 @@ INCLUDES = \
-I$(top_srcdir)/pango/ \
$(GLIB_CFLAGS)
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+endif
+
moduledir = $(libdir)/pango/$(PANGO_MODULE_VERSION)/modules
module_LTLIBRARIES =
noinst_LTLIBRARIES =
@@ -68,7 +72,7 @@ endif
thai_ft2_sources = $(common_sources) thai-fc.c
-pango_thai_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module
+pango_thai_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module $(no_undefined)
pango_thai_ft2_la_LIBADD = $(pangoft2libs)
pango_thai_ft2_la_SOURCES = $(thai_ft2_sources)
pango_thai_ft2_la_CFLAGS = -DBUILD_FT2