summaryrefslogtreecommitdiff
path: root/modules/thai/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-08-03 02:35:20 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-08-03 02:35:20 +0000
commit94f39b93e929db7881070f4b5e1f5dc3c106e3fb (patch)
tree1fa92651d4e9d2c7c41d413468f37bdb8095cd52 /modules/thai/Makefile.am
parente2ea77ce2f99c122a0087c28fcd9316be4d6e205 (diff)
downloadpango-94f39b93e929db7881070f4b5e1f5dc3c106e3fb.tar.gz
Make pangoxft depend on pangoft2.
Sat Aug 2 14:33:28 2003 Owen Taylor <otaylor@redhat.com> * pango/Makefile.am (libpangoxft_1_0_la_LIBADD): Make pangoxft depend on pangoft2. * pango/pangofc-fontmap.[ch]: Make pangofc-fontmap.cI into a real base class. * pango/pangofc-font.[ch]: Move some of the pangoxft/ pangoft2 implementation here. * pango/pangoft2.c pango/pangoft2-fontmap.c pango/pangoft2-private.h pango/pangoxft-font.c pango/pangoxft2-fontmap.c pango/pangoxft-private.h: Adapt to the new scheme * modules/*/Makefile.am Modules/*/*/*-fc.c: Don't build separate FT2 and Xft shapers, just build one Fc shaper. * docs/pango-sections.txt docs/pango-docs.sgml docs/tmpl/pangofc-font{,map}.sgml: Basic docs for the new stuff. * configure.in: Up pango_module_version to 1.4.0.
Diffstat (limited to 'modules/thai/Makefile.am')
-rw-r--r--modules/thai/Makefile.am40
1 files changed, 9 insertions, 31 deletions
diff --git a/modules/thai/Makefile.am b/modules/thai/Makefile.am
index d093c6f2..bfa4a78e 100644
--- a/modules/thai/Makefile.am
+++ b/modules/thai/Makefile.am
@@ -1,8 +1,6 @@
## Process this file with automake to create Makefile.in.
pangolibs = $(top_builddir)/pango/libpango-$(PANGO_API_VERSION).la $(GLIB_LIBS)
-pangoxlibs = $(top_builddir)/pango/libpangox-$(PANGO_API_VERSION).la $(X_LIBS) $(pangolibs)
-pangoxftlibs = $(top_builddir)/pango/libpangoxft-$(PANGO_API_VERSION).la $(XFT_LIBS) $(pangolibs)
pangoft2libs = $(top_builddir)/pango/libpangoft2-$(PANGO_API_VERSION).la $(FREETYPE_LIBS) $(pangolibs)
INCLUDES = \
@@ -24,42 +22,22 @@ noinst_LTLIBRARIES =
common_sources = thai-shaper.c thai-shaper.h
-if HAVE_XFT
-INCLUDES += $(XFT_CFLAGS)
-if INCLUDE_THAI_XFT
-noinst_LTLIBRARIES += libpango-thai-xft.la
-else
-module_LTLIBRARIES += pango-thai-xft.la
-endif
-endif
-
-thai_xft_sources = $(common_sources) thai-fc.c
-
-pango_thai_xft_la_LDFLAGS = -export-dynamic -avoid-version -module
-pango_thai_xft_la_LIBADD = $(pangoxftlibs)
-pango_thai_xft_la_SOURCES = $(thai_xft_sources)
-pango_thai_xft_la_CFLAGS = -DBUILD_XFT
-libpango_thai_xft_la_SOURCES = $(thai_xft_sources)
-libpango_thai_xft_la_CFLAGS = -DBUILD_XFT -DPANGO_MODULE_PREFIX=_pango_thai_xft
-
-
if HAVE_FREETYPE
INCLUDES += $(FREETYPE_CFLAGS)
-if INCLUDE_THAI_FT2
-noinst_LTLIBRARIES += libpango-thai-ft2.la
+if INCLUDE_THAI_FC
+noinst_LTLIBRARIES += libpango-thai-fc.la
else
-module_LTLIBRARIES += pango-thai-ft2.la
+module_LTLIBRARIES += pango-thai-fc.la
endif
endif
-thai_ft2_sources = $(common_sources) thai-fc.c
+thai_fc_sources = $(common_sources) thai-fc.c
-pango_thai_ft2_la_LDFLAGS = -export-dynamic -avoid-version -module $(no_undefined)
-pango_thai_ft2_la_LIBADD = $(pangoft2libs)
-pango_thai_ft2_la_SOURCES = $(thai_ft2_sources)
-pango_thai_ft2_la_CFLAGS = -DBUILD_FT2
-libpango_thai_ft2_la_SOURCES = $(thai_ft2_sources)
-libpango_thai_ft2_la_CFLAGS = -DBUILD_FT2 -DPANGO_MODULE_PREFIX=_pango_thai_ft2
+pango_thai_fc_la_LDFLAGS = -export-dynamic -avoid-version -module $(no_undefined)
+pango_thai_fc_la_LIBADD = $(pangoft2libs)
+pango_thai_fc_la_SOURCES = $(thai_fc_sources)
+libpango_thai_fc_la_SOURCES = $(thai_fc_sources)
+libpango_thai_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_fc
included-modules: $(noinst_LTLIBRARIES)