summaryrefslogtreecommitdiff
path: root/pango/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-07-23 15:40:18 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-10-12 18:54:17 +0530
commit86855b6a458fd9b82d246f723a7e3c9cdb37a8a0 (patch)
tree24323ebc05cb1349bdd3cc599dfda7e9219b7b00 /pango/meson.build
parent962cf9a41942f998e25d5d22b2110b85b670b718 (diff)
downloadpango-86855b6a458fd9b82d246f723a7e3c9cdb37a8a0.tar.gz
meson: Add subproject fallbacks for most dependencies
glib, fribidi, harfbuzz, fontconfig, freetype, cairo + small fixes when building as a subproject Only fribidi and glib have been added as wraps because the rest are not upstream yet and can be found at: https://github.com/centricular/harfbuzz https://github.com/centricular/fontconfig https://github.com/centricular/cairo https://github.com/centricular/freetype2 They need testing on non-Linux platforms.
Diffstat (limited to 'pango/meson.build')
-rw-r--r--pango/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/pango/meson.build b/pango/meson.build
index 254b169a..0466915f 100644
--- a/pango/meson.build
+++ b/pango/meson.build
@@ -159,7 +159,6 @@ pkgconfig.generate(libpango,
version: meson.project_version(),
filebase: 'pango',
subdirs: pango_api_name,
- requires: gobject_dep,
install_dir: join_paths(pango_libdir, 'pkgconfig'),
)
@@ -256,10 +255,13 @@ if build_pangoft2
else
# For usage as a subproject
libpangoft2_dep = dependency('', required : false)
+ # Needed for making ft2 no-op while generating pangoxft_gir below
+ pangoft2_gir_dep = dependency('', required : false)
+ pangoft2_gir = [[]]
endif
# Xft
-if xft_dep.found()
+if xft_dep.found() and fontconfig_dep.found()
pangoxft_headers = [
'pangoxft.h',
'pangoxft-render.h',