summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2021-01-24 11:02:21 -0500
committerMatthias Clasen <mclasen@redhat.com>2021-01-24 16:42:57 -0500
commit49b1f80a83433e5ddb18bd4e1577171fef8641e5 (patch)
treeda11169c87840011970de5e27f3ded4c3a96b3e5 /tests/meson.build
parentbc973fdb04b3f4b13c58738ed88c576c58df8b85 (diff)
downloadpango-fix-font-roundtrip.tar.gz
tests: Add tests for pango_font_describefix-font-roundtrip
Test that round-tripping through pango_font_describe works. This is currently broken for scalable bitmap fonts, such as color Emoji fonts. We skip the test on OS X where we are most likely missing the fonts.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index ba96ac2c..bdccd55d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -8,6 +8,8 @@ endif
if host_system == 'windows'
test_cflags += '-DHAVE_WIN32'
+elif host_system == 'darwin'
+ test_cflags += '-DHAVE_CARBON'
endif
test_env = environment()