summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 96ecbcc9..3ec19b51 100644
--- a/configure.in
+++ b/configure.in
@@ -153,7 +153,12 @@ AM_CONDITIONAL(HAVE_XFT, $have_xft)
have_win32=false
WIN32_LIBS=""
WIN32_CFLAGS=""
-AC_CHECK_LIB(gdi32, GetTextMetricsA@8, have_win32=true, : )
+# The following doesn't work with autoconf-2.13, so we check $host instead
+# AC_CHECK_LIB(gdi32, GetTextMetricsA@8, have_win32=true, : )
+case "$host" in
+ *-*-mingw*|*-*-cygwin*) have_win32=true ;;
+esac
+
if test $have_win32 = true; then
WIN32_LIBS="-lgdi32"