summaryrefslogtreecommitdiff
path: root/modules/thai/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/thai/Makefile.am')
-rw-r--r--modules/thai/Makefile.am12
1 files changed, 1 insertions, 11 deletions
diff --git a/modules/thai/Makefile.am b/modules/thai/Makefile.am
index ba9fa842..79ba7213 100644
--- a/modules/thai/Makefile.am
+++ b/modules/thai/Makefile.am
@@ -2,19 +2,9 @@ include $(top_srcdir)/modules/Module.mk
if INCLUDE_THAI_LANG
noinst_LTLIBRARIES += libpango-thai-lang.la
-else
-if DYNAMIC_THAI_LANG
-module_LTLIBRARIES += pango-thai-lang.la
endif
-endif
-
-lang_sources = \
- thai-lang.c
-pango_thai_lang_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
-pango_thai_lang_la_LIBADD = $(pangolibs) $(LIBTHAI_LIBS)
-pango_thai_lang_la_SOURCES = $(lang_sources)
-libpango_thai_lang_la_SOURCES = $(lang_sources)
+libpango_thai_lang_la_SOURCES = thai-lang.c
libpango_thai_lang_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_thai_lang $(LIBTHAI_CFLAGS)
libpango_thai_lang_la_LIBADD = $(LIBTHAI_LIBS)