summaryrefslogtreecommitdiff
path: root/trunk/modules/arabic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/modules/arabic/Makefile.am')
-rw-r--r--trunk/modules/arabic/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/trunk/modules/arabic/Makefile.am b/trunk/modules/arabic/Makefile.am
new file mode 100644
index 00000000..26b232eb
--- /dev/null
+++ b/trunk/modules/arabic/Makefile.am
@@ -0,0 +1,41 @@
+include $(top_srcdir)/modules/Module.mk
+
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_ARABIC_FC
+noinst_LTLIBRARIES += libpango-arabic-fc.la
+else
+if DYNAMIC_ARABIC_FC
+module_LTLIBRARIES += pango-arabic-fc.la
+endif
+endif
+endif
+
+fc_sources = \
+ arabic-fc.c \
+ arabic-ot.c \
+ arabic-ot.h
+
+pango_arabic_fc_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
+pango_arabic_fc_la_LIBADD = $(pangoft2libs)
+pango_arabic_fc_la_SOURCES = $(fc_sources)
+libpango_arabic_fc_la_SOURCES = $(fc_sources)
+libpango_arabic_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_arabic_fc
+
+
+if INCLUDE_ARABIC_LANG
+noinst_LTLIBRARIES += libpango-arabic-lang.la
+else
+if DYNAMIC_ARABIC_LANG
+module_LTLIBRARIES += pango-arabic-lang.la
+endif
+endif
+
+lang_sources = \
+ arabic-lang.c
+
+pango_arabic_lang_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
+pango_arabic_lang_la_LIBADD = $(pangolibs)
+pango_arabic_lang_la_SOURCES = $(lang_sources)
+libpango_arabic_lang_la_SOURCES = $(lang_sources)
+libpango_arabic_lang_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_arabic_lang