summaryrefslogtreecommitdiff
path: root/trunk/modules/tibetan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/modules/tibetan/Makefile.am')
-rw-r--r--trunk/modules/tibetan/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/trunk/modules/tibetan/Makefile.am b/trunk/modules/tibetan/Makefile.am
new file mode 100644
index 00000000..3b7959dc
--- /dev/null
+++ b/trunk/modules/tibetan/Makefile.am
@@ -0,0 +1,20 @@
+include $(top_srcdir)/modules/Module.mk
+
+if HAVE_FREETYPE
+INCLUDES += $(FREETYPE_CFLAGS)
+if INCLUDE_TIBETAN_FC
+noinst_LTLIBRARIES += libpango-tibetan-fc.la
+else
+if DYNAMIC_TIBETAN_FC
+module_LTLIBRARIES += pango-tibetan-fc.la
+endif
+endif
+endif
+
+tibetan_fc_sources = $(common_sources) tibetan-fc.c
+
+pango_tibetan_fc_la_LDFLAGS = -module $(MODULE_LIBTOOL_OPTIONS)
+pango_tibetan_fc_la_LIBADD = $(pangoft2libs)
+pango_tibetan_fc_la_SOURCES = $(tibetan_fc_sources)
+libpango_tibetan_fc_la_SOURCES = $(tibetan_fc_sources)
+libpango_tibetan_fc_la_CFLAGS = -DPANGO_MODULE_PREFIX=_pango_tibetan_fc