summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeff Forcier <jeff@bitprophet.org>2018-09-17 17:58:44 -0700
committerJeff Forcier <jeff@bitprophet.org>2018-09-17 17:58:44 -0700
commit4cc767f5cd109a459571abbf21c68b783ce237c9 (patch)
tree68338fb6f9dc72cfaf8ee0ef5ef6cc572f613403 /setup.py
parentab823cc9836b8f3ec7cdd916f0dc53f0096e1c59 (diff)
parent068b0914e396e8a47e28245a0a69ea7bf6bea6ff (diff)
downloadparamiko-4cc767f5cd109a459571abbf21c68b783ce237c9.tar.gz
Merge branch '2.1' into 2.2
Foregoes a handful of unblackened bits to make the merge easier; will blacken next anyways
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py50
1 files changed, 25 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 1038fb68..49fe63e3 100644
--- a/setup.py
+++ b/setup.py
@@ -19,12 +19,12 @@
import sys
from setuptools import setup
-if sys.platform == 'darwin':
+if sys.platform == "darwin":
import setup_helper
setup_helper.install_custom_make_tarball()
-longdesc = '''
+longdesc = """
This is a library for making SSH2 connections (client or server).
Emphasis is on using SSH2 as an alternative to SSL for making secure
connections between python scripts. All major ciphers and hash methods
@@ -35,14 +35,14 @@ Required packages:
To install the development version, ``pip install -e
git+https://github.com/paramiko/paramiko/#egg=paramiko``.
-'''
+"""
# Version info -- read without importing
_locals = {}
-with open('paramiko/_version.py') as fp:
+with open("paramiko/_version.py") as fp:
exec(fp.read(), None, _locals)
-version = _locals['__version__']
+version = _locals["__version__"]
setup(
name="paramiko",
@@ -52,27 +52,27 @@ setup(
author="Jeff Forcier",
author_email="jeff@bitprophet.org",
url="https://github.com/paramiko/paramiko/",
- packages=['paramiko'],
- license='LGPL',
- platforms='Posix; MacOS X; Windows',
+ packages=["paramiko"],
+ license="LGPL",
+ platforms="Posix; MacOS X; Windows",
classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: '
- 'GNU Library or Lesser General Public License (LGPL)',
- 'Operating System :: OS Independent',
- 'Topic :: Internet',
- 'Topic :: Security :: Cryptography',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: "
+ "GNU Library or Lesser General Public License (LGPL)",
+ "Operating System :: OS Independent",
+ "Topic :: Internet",
+ "Topic :: Security :: Cryptography",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
],
install_requires=[
'bcrypt>=3.1.3',