summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeff Forcier <jeff@bitprophet.org>2021-10-01 15:12:46 -0400
committerJeff Forcier <jeff@bitprophet.org>2021-10-01 22:04:36 -0400
commit985c5d0c811987a9d4d9fff712169e5125acc95a (patch)
tree0039ec3ea3c9ddf3aee64aa6a868eac0c32ca362 /setup.py
parent6359fb16d4d31a0ae1cdca865dd428334023a363 (diff)
downloadparamiko-985c5d0c811987a9d4d9fff712169e5125acc95a.tar.gz
README / www-index overhaul
- Nuke old README in its entirety: - We don't want people using demos if possible, stop advertising them - Nix a bunch of bits that will now be replaced by standard PyPI sidebar links (docs, tests etc) - Ditto the 'headers', most of that stuff is either PyPI metadata or the about to be added shields.io badges - Some stuff deleted was also just old, eg IRC is no longer a support channel and I think librelist is dead too - Rip out www site index for use as README and inject back in via include - Rewrite a bunch of that too for clarity - Leverage it in long_description too
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 1 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 93c08d15..428f231b 100644
--- a/setup.py
+++ b/setup.py
@@ -24,15 +24,7 @@ if sys.platform == "darwin":
setup_helper.install_custom_make_tarball()
-text = open("README.rst").read()
-long_description = """
-To find out what's new in this version of Paramiko, please see `the changelog
-<https://www.paramiko.org/changelog.html#{}>`_.
-
-{}
-""".format(
- version, text
-)
+long_description = open("README.rst").read()
# Version info -- read without importing
_locals = {}