summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeff Forcier <jeff@bitprophet.org>2021-10-08 13:44:29 -0400
committerJeff Forcier <jeff@bitprophet.org>2021-10-08 13:44:29 -0400
commitb3a7f365ba67d1f08bf295052778ffbf33c5a2e0 (patch)
tree2f6096e764e5d466b2709b89ca1d083c7fbed914 /setup.py
parente5d9dcced95948ef61df2b5d500d37216b8f781f (diff)
downloadparamiko-b3a7f365ba67d1f08bf295052778ffbf33c5a2e0.tar.gz
Expand an old slightly confusing comment
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 824786eb..56997532 100644
--- a/setup.py
+++ b/setup.py
@@ -86,7 +86,10 @@ setup(
"Programming Language :: Python :: 3.9",
],
# TODO 3.0: remove bcrypt, pynacl and update installation docs noting that
- # use of the extras_require(s) is now required for those
+ # use of the extras_require ("paramiko[ed2559]") is now required for those
+ # TODO 3.0: alternately, given how prevalent ed25519 is now, and how we use
+ # invoke for (increasing) subproc stuff, consider making the default flavor
+ # "full" and adding a "minimal" or similar that is just-crypto?
install_requires=["bcrypt>=3.1.3", "cryptography>=2.5", "pynacl>=1.0.1"],
extras_require=extras_require,
)