summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDorian Pula <dorian.pula@amber-penguin-software.ca>2017-05-23 16:36:21 -0700
committerJeff Forcier <jeff@bitprophet.org>2017-05-31 17:14:40 -0700
commitc1a0974d8886c6a2d46fb69a4a7df382875374c2 (patch)
tree9ee49c23a56b8bed833a081248146f07263a85fd /setup.py
parentad4cddfb3b684b21ddcbf3ac8bc9a29fc0c9c81c (diff)
downloadparamiko-c1a0974d8886c6a2d46fb69a4a7df382875374c2.tar.gz
Fix flake8 for top-level modules.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py41
1 files changed, 20 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 2e0d4041..80d5ea7f 100644
--- a/setup.py
+++ b/setup.py
@@ -16,6 +16,13 @@
# along with Paramiko; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Suite 500, Boston, MA 02110-1335 USA.
+import sys
+from setuptools import setup
+
+if sys.platform == 'darwin':
+ import setup_helper
+
+ setup_helper.install_custom_make_tarball()
longdesc = '''
This is a library for making SSH2 connections (client or server).
@@ -30,14 +37,6 @@ To install the development version, ``pip install -e
git+https://github.com/paramiko/paramiko/#egg=paramiko``.
'''
-import sys
-from setuptools import setup
-
-
-if sys.platform == 'darwin':
- import setup_helper
- setup_helper.install_custom_make_tarball()
-
# Version info -- read without importing
_locals = {}
@@ -45,22 +44,22 @@ with open('paramiko/_version.py') as fp:
exec(fp.read(), None, _locals)
version = _locals['__version__']
-
setup(
- name = "paramiko",
- version = version,
- description = "SSH2 protocol library",
- long_description = longdesc,
- author = "Jeff Forcier",
- author_email = "jeff@bitprophet.org",
- url = "https://github.com/paramiko/paramiko/",
- packages = [ 'paramiko' ],
- license = 'LGPL',
- platforms = 'Posix; MacOS X; Windows',
- classifiers = [
+ name="paramiko",
+ version=version,
+ description="SSH2 protocol library",
+ long_description=longdesc,
+ author="Jeff Forcier",
+ author_email="jeff@bitprophet.org",
+ url="https://github.com/paramiko/paramiko/",
+ packages=['paramiko'],
+ license='LGPL',
+ platforms='Posix; MacOS X; Windows',
+ classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
+ 'License :: OSI Approved :: '
+ 'GNU Library or Lesser General Public License (LGPL)',
'Operating System :: OS Independent',
'Topic :: Internet',
'Topic :: Security :: Cryptography',