summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJeff Forcier <jeff@bitprophet.org>2023-01-09 17:03:28 -0500
committerJeff Forcier <jeff@bitprophet.org>2023-01-09 19:33:39 -0500
commitdefe76d8e324b6d8a1ee2a04f153b17a9c3a56c7 (patch)
tree54eb9587f58879d245bf6b4094503d1cb80439b2 /setup.py
parentd87c64c9f57de0517442fc180929a29bfd964f0a (diff)
downloadparamiko-defe76d8e324b6d8a1ee2a04f153b17a9c3a56c7.tar.gz
Classifiers, python_requires update
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index a8207ac2..8ff8c94c 100644
--- a/setup.py
+++ b/setup.py
@@ -75,15 +75,13 @@ setup(
"Topic :: Internet",
"Topic :: Security :: Cryptography",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
],
# TODO 3.0: remove bcrypt, pynacl and update installation docs noting that
# use of the extras_require ("paramiko[ed2559]") is now required for those
@@ -92,6 +90,7 @@ setup(
# "full"/"all"? (probably sans gssapi which should remain optional; MAYBE
# still sans invoke as well, not everyone uses ProxyCommand or Match exec)
# TODO 3.0: remove six, obviously
+ python_requires=">=3.6",
install_requires=[
"bcrypt>=3.1.3",
"cryptography>=2.5",