summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 2 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 8ff8c94c..fda27c61 100644
--- a/setup.py
+++ b/setup.py
@@ -40,8 +40,9 @@ extras_require = {
'gssapi>=1.4.1;platform_system!="Windows"',
'pywin32>=2.1.8;platform_system=="Windows"',
],
- "ed25519": ["pynacl>=1.0.1", "bcrypt>=3.1.3"],
"invoke": ["invoke>=2.0"],
+ # TODO 4.0: remove entrypoint as irrelevant
+ "ed25519": [],
}
everything = []
for subdeps in extras_require.values():
@@ -83,19 +84,11 @@ setup(
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
],
- # TODO 3.0: remove bcrypt, pynacl and update installation docs noting that
- # use of the extras_require ("paramiko[ed2559]") is now required for those
- # TODO 3.0: alternately, given how prevalent ed25519 is now, and how we use
- # invoke for (increasing) subproc stuff, consider making the default flavor
- # "full"/"all"? (probably sans gssapi which should remain optional; MAYBE
- # still sans invoke as well, not everyone uses ProxyCommand or Match exec)
- # TODO 3.0: remove six, obviously
python_requires=">=3.6",
install_requires=[
"bcrypt>=3.1.3",
"cryptography>=2.5",
"pynacl>=1.0.1",
- "six",
],
extras_require=extras_require,
)