summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-03-02 11:55:50 +0100
committerJim Meyering <jim@meyering.net>2007-03-02 11:55:50 +0100
commit478c89f683083a768fb47d33059af3005bf3be82 (patch)
treec2474b4a74cd5115cdcbb46d1355a69d34b7c646 /Makefile.am
parent852b9c08a7a1ae8ec7e58145a7f128cf69cbaa2f (diff)
downloadparted-478c89f683083a768fb47d33059af3005bf3be82.tar.gz
Add infrastructure for more rigorous "make distcheck" rules.
* GNUmakefile: New file. * .prev-version: New file. * Makefile.am (MAINTAINERCLEANFILES): Remove names of files now in build-aux/. (distcheck-hook): New rule, to run the checks in Makefile.maint. (EXTRA_DIST): Add .prev-version. * Makefile.maint: New file. Improved "make distcheck" rules. * Makefile.cfg: Select which Makefile.maint checks to run. (local-checks-to-skip): List all currently-failing and irrelevant tests here. * build-aux/vc-list-files: New file. List version-controlled files. * .gitignore: Remove build-aux, since now it contains a version-controlled file.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 15 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 15dacb6..ebb9487 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,13 +1,17 @@
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = po lib libparted parted partprobe include doc debug
-EXTRA_DIST = \
- BUGS \
- libparted.pc.in \
- parted.spec.in \
- parted.spec \
- scripts/data/abi/baseline_symbols.txt \
- scripts/extract_symvers
+EXTRA_DIST = \
+ .prev-version \
+ BUGS \
+ libparted.pc.in \
+ parted.spec.in \
+ parted.spec \
+ scripts/data/abi/baseline_symbols.txt \
+ scripts/extract_symvers \
+ Makefile.cfg \
+ Makefile.maint \
+ GNUmakefile
aclocaldir=$(datadir)/aclocal
@@ -22,6 +26,9 @@ parted.spec: parted.spec.in
mv $@-tmp $@
MAINTAINERCLEANFILES = parted.spec
+distcheck-hook:
+ $(MAKE) my-distcheck
+
### ABI Checking scripts ###
baseline_file = ${top_srcdir}/scripts/data/abi/baseline_symbols.txt
@@ -63,16 +70,5 @@ MAINTAINERCLEANFILES += \
ABOUT-NLS \
ChangeLog \
INSTALL \
- Makefile.in \
aclocal.m4 \
- compile \
- config.guess \
- config.h.in \
- config.rpath \
- config.sub \
- configure \
- depcomp \
- install-sh \
- ltmain.sh \
- missing \
- mkinstalldirs
+ configure