summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-12-09 17:20:47 +0100
committerJim Meyering <meyering@redhat.com>2009-12-09 17:20:47 +0100
commitacece8bc5b1e1f40af5d15a4742e1bed6a411085 (patch)
treef1e7e0ff1529b3b83ae88ab6bee8b75cea557bd5 /Makefile.am
parent9fecf09a7c8b7b5a05a17c51d7c3e97977168f50 (diff)
downloadparted-acece8bc5b1e1f40af5d15a4742e1bed6a411085.tar.gz
build: make it clear which sector size is in use upon test failure
* Makefile.am (ss-1024 ss-2048 ss-4096): New targets. Before this, top-level "make check" would lead to four separate runs through all the regression tests, one for each of the following simulated sector sizes: 1024 2048 4096, and one more for the native (usually 512), and it was not easy to tell which sector size was in use for a failing test. Now, we still perform exactly the same tests, but the sector size is now part of each target name.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3d0ce15..0e80967 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -76,13 +76,17 @@ MAINTAINERCLEANFILES += \
aclocal.m4 \
configure
+.PHONY: ss-1024 ss-2048 ss-4096
+ss-1024 ss-2048 ss-4096:
+ PARTED_SECTOR_SIZE=$(ss-,,$@) $(MAKE) check-recursive
+
# Run the regression test suite with different settings,
# to ensure it works with simulated partition sizes > 512.
.PHONY: check-other-sector_sizes
check-other-sector_sizes:
- PARTED_SECTOR_SIZE=1024 $(MAKE) check-recursive
- PARTED_SECTOR_SIZE=2048 $(MAKE) check-recursive
- PARTED_SECTOR_SIZE=4096 $(MAKE) check-recursive
+ $(MAKE) ss-1024
+ $(MAKE) ss-2048
+ $(MAKE) ss-4096
check: check-other-sector_sizes