summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2006-12-11 07:46:33 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2006-12-11 07:46:33 -0200
commit38f29307583865f83117aa7c7c85a297feefad18 (patch)
tree5ed0037540205bbd98ff60e599da84398a09db11 /configure.ac
parentab143e1794c06ee5828450ec48ebccd2a89adfa4 (diff)
downloadparted-38f29307583865f83117aa7c7c85a297feefad18.tar.gz
Add CHECK unittext library detection to Autoconf script
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8200564..5dc4ebc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,6 +432,10 @@ AC_CHECK_HEADER([execinfo.h], [
])
])
+dnl check for "check", unit testing library/header
+PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
+AM_CONDITIONAL(HAVE_CHECK, test "x$CHECK_LIBS" != "x")
+
dnl Checks for typedefs, structures and compiler characteristics.
AC_PROG_LD
@@ -486,6 +490,7 @@ libparted/fs/ntfs/Makefile
libparted/fs/reiserfs/Makefile
libparted/fs/ufs/Makefile
libparted/fs/xfs/Makefile
+libparted/tests/Makefile
parted/Makefile
partprobe/Makefile
doc/Makefile