summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-11-05 23:33:37 +0100
committerBrian C. Lane <bcl@redhat.com>2017-12-19 09:50:55 -0800
commit571293e3f9ee45f37867578899c6a8a9cd35afd4 (patch)
tree8d9a725e9a44d14bfa7286f288894ffc200224d1 /configure.ac
parent465fdd8d72e7f8517d67ec7b5f227f5482928ec1 (diff)
downloadparted-571293e3f9ee45f37867578899c6a8a9cd35afd4.tar.gz
libparted/labels: link with libiconv if needed
gpt.c uses iconv so it should link with it. Otherwise, on platforms where libiconv is a separate library, we get a link failure of parted: CCLD parted ../libparted/.libs/libparted.so: undefined reference to `libiconv' ../libparted/.libs/libparted.so: undefined reference to `libiconv_open' ../libparted/.libs/libparted.so: undefined reference to `libiconv_close' Since iconv functionality is needed unconditionally (not only when gettext is enabled), AM_ICONV needs to be added to configure.ac.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d158793..738c697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,6 +288,8 @@ fi
AC_PROG_LIBTOOL
LT_INIT
+AM_ICONV
+
AM_GNU_GETTEXT_VERSION([0.18])
AM_GNU_GETTEXT([external])
if test "$USE_INCLUDED_LIBINTL" = "yes"; then