summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-07-19 09:03:59 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-07-19 11:59:07 -0300
commit6b96e557531db279d30cd3d592f3ce46eba24b5b (patch)
treeb139a579d3745686fc3404b8f371d3b7afd76256 /configure.ac
parentaef3939a693b3ccc046324c3bf806cc64feda7c7 (diff)
downloadparted-6b96e557531db279d30cd3d592f3ce46eba24b5b.tar.gz
Avoid compilation failure on s390
To export LinuxSpecific stuff for labels, in this case fdasd, we now provide arch/linux.h. This aids in avoiding code duplication. * configure.ac: add BUILD_LINUX conditional. * libparted/Makefile.am: conditionally use linux.h. * libparted/arch/linux.c: move LinuxSpecific stuff to linux.h. * libparted/arch/linux.h: New file. * libparted/labels/Makefile.am: include from libparted as well. * libparted/labels/dasd.c: use arch/linux.h and use dev->path for error message. * libparted/labels/fdasd.c: include linux.h and drop an unused variable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 36342d5..f2fd34e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -474,6 +474,7 @@ AC_CHECK_HEADER([execinfo.h], [
])
AM_CONDITIONAL([COMPILE_FOR_S390], [test "$host_cpu" = s390 || test "$host_cpu" = s390x])
+AM_CONDITIONAL([BUILD_LINUX], [test "$OS" = linux])
dnl check for "check", unit testing library/header
PKG_CHECK_MODULES([CHECK], [check >= 0.9.3], have_check=yes, have_check=no)