summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnant Narayanan <anant@kix.in>2006-12-14 22:00:59 +0530
committerAnant Narayanan <anant@kix.in>2006-12-14 22:00:59 +0530
commit8acac4f1497e55447d931df8a128af3a14452385 (patch)
treeb823d7845ed6492448e744b7ed383505ea47b471 /configure.ac
parent45713930032b8e0664287a6cb354509f7df281e7 (diff)
downloadparted-8acac4f1497e55447d931df8a128af3a14452385.tar.gz
Loosen requirement for the 'check' library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5dc4ebc..6d52fbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -433,8 +433,11 @@ AC_CHECK_HEADER([execinfo.h], [
])
dnl check for "check", unit testing library/header
-PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
-AM_CONDITIONAL(HAVE_CHECK, test "x$CHECK_LIBS" != "x")
+PKG_CHECK_MODULES([CHECK], [check >= 0.9.3], have_check=yes, have_check=no)
+if test "$have_scintilla" != "yes"; then
+ AC_MSG_RESULT([Unable to locate check version 0.9.3 or higher: not building])
+fi
+AM_CONDITIONAL([HAVE_CHECK], [test "$have_check" = yes])
dnl Checks for typedefs, structures and compiler characteristics.
AC_PROG_LD