summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@ubuntu.com>2015-09-21 12:10:02 +0100
committerPhillip Susi <psusi@ubuntu.com>2018-06-05 10:58:12 -0400
commitb49388018931cab220b9dd50f3a2bd51401e48af (patch)
tree5c7e3ce4b6c9b09dd0de0e24d357a18978c00720 /configure.ac
parent247e3fc6cd8bca79b7c0362886ae9b5b06ba6f8c (diff)
downloadparted-b49388018931cab220b9dd50f3a2bd51401e48af.tar.gz
build: Remove unused traces of dynamic loading
Now that file system operations have been removed from libparted, libreiserfs is no longer used. Remove references to it, along with the dynamic loading build infrastructure which was only used for libreiserfs. Signed-off-by: Colin Watson <cjwatson@ubuntu.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 0 insertions, 49 deletions
diff --git a/configure.ac b/configure.ac
index 056478f..8413e06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,20 +103,6 @@ if test "$enable_discover_only" = yes; then
fi
PARTED_LIBS=""
-AC_ARG_ENABLE([dynamic-loading],
-[ --enable-dynamic-loading support dynamic fs libraries [default=yes]], ,
- if test "$enable_discover_only" = yes; then
- enable_dynamic_loading=no
- else
- enable_dynamic_loading=yes
- fi
-)
-if test "$enable_discover_only" = yes \
- && test "$enable_dynamic_loading" = yes; then
- AC_MSG_ERROR(
-[You can't use --enable-dynamic-loading and --disable-discover-only together]
- )
-fi
AC_ARG_ENABLE([debug],
[ --enable-debug compile in assertions [default=yes]], ,
@@ -303,23 +289,6 @@ Or install gettext. GNU gettext is available from
])
fi
-dnl Check for libdl, if we are doing dynamic loading
-DL_LIBS=""
-AC_SUBST([DYNAMIC_LOADING])
-DYNAMIC_LOADING=no
-if test "$enable_dynamic_loading" = yes; then
- AC_CHECK_LIB([dl], [dlopen],
- DL_LIBS="-ldl"
- PARTED_LIBS="$PARTED_LIBS -ldl"
- DYNAMIC_LOADING=yes
- AC_DEFINE([DYNAMIC_LOADING], [1], [Lazy linking to fs libs]),
- AC_MSG_ERROR(
- [-ldl not found! Try using --disable-dynamic-loading]
- )
- )
-fi
-AC_SUBST([DL_LIBS])
-
dnl Check for libuuid
UUID_LIBS=""
AC_CHECK_LIB([uuid], [uuid_generate], [UUID_LIBS="-luuid"],
@@ -357,24 +326,6 @@ if test "$enable_selinux" = yes; then
fi
AC_SUBST([SELINUX_LIBS])
-dnl Check for libreiserfs
-REISER_LIBS=""
-if test "$enable_dynamic_loading" = no && test "$enable_discover_only" = no; then
- OLD_LIBS="$LIBS"
- AC_CHECK_LIB([dal], [dal_equals],
- LIBS="-ldal"
- AC_CHECK_LIB([reiserfs], [reiserfs_fs_probe],
- REISER_LIBS="-ldal -lreiserfs"
- AC_DEFINE([HAVE_LIBREISERFS], [1], [Have libreiserfs])
- )
- AC_CHECK_LIB([reiserfs], [reiserfs_fs_check],
- AC_DEFINE([HAVE_REISERFS_FS_CHECK], [1], [Have reiserfs_fs_check()])
- )
- )
- LIBS="$OLD_LIBS"
-fi
-AC_SUBST([REISER_LIBS])
-
dnl Check for termcap
if test "$with_readline" = yes; then
OLD_LIBS="$LIBS"