summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-08-18 21:24:53 +0200
committerJim Meyering <meyering@redhat.com>2009-08-18 22:25:21 +0200
commitd116e8e5b337b4eb379cef39eaec255d26a1b553 (patch)
tree749250bbcfb3f99e9c90af90e33a688d81b3f573 /configure.ac
parent7338274ec849503c552e2d4824f3fdabad2279ea (diff)
downloadparted-d116e8e5b337b4eb379cef39eaec255d26a1b553.tar.gz
build: ignore new -Wjump-misses-init warnings
* configure.ac: Ignore warnings from gcc's new -Wjump-misses-init.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17958a0..0500b5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,6 +256,9 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-macros]) # Too many warnings for now
+ # FIXME: investigate these
+ gl_WARN_ADD([-Wno-jump-misses-init])
+
# In spite of excluding -Wlogical-op above, it is enabled, as of
# gcc 4.5.0 20090517, and it provokes warnings in cat.c, dd.c, truncate.c
gl_WARN_ADD([-Wno-logical-op])