summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian C. Lane <bcl@redhat.com>2018-10-17 16:56:44 -0700
committerBrian C. Lane <bcl@redhat.com>2019-08-09 11:54:54 -0700
commitf6b51897d0f2b5e149defe4901965d056cb6ebd7 (patch)
tree41206084786ddd0a9ee7afad58b8e150b111cb1d /configure.ac
parentfd189bb087632300dae75903061ec7d8c4742fe0 (diff)
downloadparted-f6b51897d0f2b5e149defe4901965d056cb6ebd7.tar.gz
Adjust the gcc warnings to recognize FALLTHROUGH
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 281aad7..7ab056b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,6 +241,9 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-fdiagnostics-show-option])
+ # Make sure it recognizes /* FALLTHROUGH */ comment
+ gl_WARN_ADD([-Wimplicit-fallthrough=3])
+
AC_SUBST([WARN_CFLAGS])
AC_DEFINE([lint], [1], [Define to 1 if the compiler is checking for lint.])