summaryrefslogtreecommitdiff
path: root/include/parted/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2007-03-19 11:20:55 -0400
committerDavid Cantrell <dcantrell@redhat.com>2007-03-19 20:58:45 -0400
commit5167881e1f44c1bd4ccf4ed15daeeaa7af75558d (patch)
tree8ad99fb3f2640c59de77273854caee9de341f539 /include/parted/Makefile.am
parent04f2111580d683dbc252ac1765e5874fc1444f81 (diff)
downloadparted-5167881e1f44c1bd4ccf4ed15daeeaa7af75558d.tar.gz
Remove the COMPILE_FOR_S390 flag-setting stuff. It wasn't correct anyway. Take a kernel-style approach and check uname -m to see if we are on s390. If so, we build for zSeries. Otherwise we do not.
Diffstat (limited to 'include/parted/Makefile.am')
-rw-r--r--include/parted/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/parted/Makefile.am b/include/parted/Makefile.am
index dd0e1d4..c91b8bc 100644
--- a/include/parted/Makefile.am
+++ b/include/parted/Makefile.am
@@ -1,7 +1,8 @@
-if COMPILE_FOR_S390
-S390_HDRS = fdasd.h vtoc.h
-else
+ZARCH = $(shell uname -m 2>/dev/null | tr [A-Z] [a-z] | sed -e 's/s390x/s390/g)
+
S390_HDRS =
+ifeq ($(ZARCH),s390)
+S390_HDRS = fdasd.h vtoc.h
endif
partedincludedir = $(includedir)/parted