summaryrefslogtreecommitdiff
path: root/libparted/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-07-09 19:07:01 +0200
committerJim Meyering <meyering@redhat.com>2009-07-09 19:23:05 +0200
commitb4bd5b6c1f1cfdbee02820b5dff2a5ec77226bce (patch)
treeee043379676f14a3e9590407344835d3853899fa /libparted/tests/Makefile.am
parentb66c47841420c5295ee0ad39ad9637c78f107960 (diff)
downloadparted-b4bd5b6c1f1cfdbee02820b5dff2a5ec77226bce.tar.gz
tests: better quoting to avoid failure with poorly-named src directory
* libparted/tests/Makefile.am (init.sh): Quote, in case $(abs_top_srcdir) contains e.g., spaces. * tests/Makefile.am (init.sh): Likewise. * libparted/tests/t2000-disk.sh: Better quoting here, too. * libparted/tests/t1000-label.sh: Likewise. Reported by Joel Granados
Diffstat (limited to 'libparted/tests/Makefile.am')
-rw-r--r--libparted/tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/libparted/tests/Makefile.am b/libparted/tests/Makefile.am
index 197b02d..d2a7176 100644
--- a/libparted/tests/Makefile.am
+++ b/libparted/tests/Makefile.am
@@ -25,9 +25,9 @@ CLEANFILES = init.sh
all: init.sh
init.sh: Makefile.in
rm -f $@-t $@
- echo 'PARTED_USABLE_TEST_DIR=$(PARTED_USABLE_TEST_DIR)' > $@-t
- echo 'abs_top_srcdir=$(abs_top_srcdir)' >> $@-t
- echo 'PATH=$(abs_builddir)$(PATH_SEPARATOR)$$PATH; export PATH' >> $@-t
+ echo 'PARTED_USABLE_TEST_DIR="$(PARTED_USABLE_TEST_DIR)"' > $@-t
+ echo 'abs_top_srcdir="$(abs_top_srcdir)"' >> $@-t
+ echo 'PATH="$(abs_builddir)$(PATH_SEPARATOR)$$PATH"; export PATH' >> $@-t
chmod a-w $@-t
mv $@-t $@