summaryrefslogtreecommitdiff
path: root/libparted/tests/Makefile.am
diff options
context:
space:
mode:
authorBrian C. Lane <bcl@redhat.com>2022-08-08 13:49:09 -0700
committerBrian C. Lane <bcl@redhat.com>2022-08-15 11:35:51 -0700
commitd50b7bf2b66b7b67ee332c1af63bc1f5fdfba7ad (patch)
tree8bcc07fdc1db6d55df80106d70d9b21023c33e2c /libparted/tests/Makefile.am
parent8957382b98fd79bc06dad132ef28a0be8b46ea16 (diff)
downloadparted-d50b7bf2b66b7b67ee332c1af63bc1f5fdfba7ad.tar.gz
tests: Add a libparted test for ped_partition_set_system on gpt
Test the libparted API to make sure the flag is not cleared by calling ped_partition_set_system.
Diffstat (limited to 'libparted/tests/Makefile.am')
-rw-r--r--libparted/tests/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libparted/tests/Makefile.am b/libparted/tests/Makefile.am
index fd5cba5..260b692 100644
--- a/libparted/tests/Makefile.am
+++ b/libparted/tests/Makefile.am
@@ -3,9 +3,10 @@
#
# This file may be modified and/or distributed without restriction.
-TESTS = t1000-label.sh t2000-disk.sh t2100-zerolen.sh t3000-symlink.sh t4000-volser.sh
+TESTS = t1000-label.sh t1001-flags.sh t2000-disk.sh t2100-zerolen.sh \
+ t3000-symlink.sh t4000-volser.sh
EXTRA_DIST = $(TESTS)
-check_PROGRAMS = label disk zerolen symlink volser
+check_PROGRAMS = label disk zerolen symlink volser flags
AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
LDADD = \
@@ -24,6 +25,7 @@ disk_SOURCES = common.h common.c disk.c
zerolen_SOURCES = common.h common.c zerolen.c
symlink_SOURCES = common.h common.c symlink.c
volser_SOURCES = common.h common.c volser.c
+flags_SOURCES = common.h common.c flags.c
# Arrange to symlink to tests/init.sh.
CLEANFILES = init.sh