summaryrefslogtreecommitdiff
path: root/parted/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-03-05 18:49:55 +0100
committerJim Meyering <meyering@redhat.com>2009-03-05 18:49:55 +0100
commitbcc72af3370b9511351b451e3c96c8375346ff7c (patch)
tree808b24ffb50be662973e9dced2feefe964b32711 /parted/Makefile.am
parent855941570a4f0f173822e98d8437943c43643b5a (diff)
downloadparted-bcc72af3370b9511351b451e3c96c8375346ff7c.tar.gz
portability: use last_component, not basename
* libparted/arch/linux.c (read_device_sysfs_file): Use last_component from gnulib's basename module, not the less-portable "basename" function. (_device_get_partition_range): Likewise. Reported by Karel Zak. * debug/clearfat/Makefile.am (clearfat_LDADD): Link gnulib *after* libparted, not before. * partprobe/Makefile.am (partprobe_LDADD): Likewise. * parted/Makefile.am (parted_LDADD): Likewise.
Diffstat (limited to 'parted/Makefile.am')
-rw-r--r--parted/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/parted/Makefile.am b/parted/Makefile.am
index c699102..cb999b1 100644
--- a/parted/Makefile.am
+++ b/parted/Makefile.am
@@ -16,8 +16,8 @@ parted_SOURCES = command.c \
parted_CFLAGS = -DBUILDINFO=
parted_LDADD = \
- $(top_builddir)/lib/libparted.la \
$(top_builddir)/libparted/libparted.la \
+ $(top_builddir)/lib/libparted.la \
$(INTLLIBS) $(LIBS) \
$(PARTED_LIBS)