summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-11-19 09:12:58 +0100
committerJim Meyering <meyering@redhat.com>2010-11-20 17:04:04 +0100
commit3bbdef285df7ccb47ab2448f41cdd55c08dc244c (patch)
treee82ff1b7dc0a9d098a8ff6249bad28fd1ef7737b /tests/Makefile.am
parenta8dca36ed5c160515ea958715f8ce44c39fcb45e (diff)
downloadparted-3bbdef285df7ccb47ab2448f41cdd55c08dc244c.tar.gz
tests: remove test-lib.sh
* tests/test-lib.sh: Remove file. No longer used. * tests/Makefile.am (EXTRA_DIST): Remove test-lib.sh. (old-init.sh): Remove rule and associated uses. * tests/lvm-utils.sh (init_root_dir_): Switch to test_dir_, since that is now the only variable that remains.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f89888d..c35d404 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -48,7 +48,7 @@ TESTS = \
t9040-many-partitions.sh
EXTRA_DIST = \
- $(TESTS) test-lib.sh t-lib.sh lvm-utils.sh t-local.sh t-lvm.sh \
+ $(TESTS) t-lib.sh lvm-utils.sh t-local.sh t-lvm.sh \
init.cfg init.sh t-lib-helpers.sh
check_PROGRAMS = print-align print-max dup-clobber
@@ -63,17 +63,6 @@ parted_dir = $(abs_top_builddir)/parted
pp_dir = $(abs_top_builddir)/partprobe
sep = $(PATH_SEPARATOR)
-CLEANFILES = old-init.sh
-all: old-init.sh
-old-init.sh: Makefile.in
- rm -f $@-t $@
- echo 'PARTED_USABLE_TEST_DIR="$(PARTED_USABLE_TEST_DIR)"' > $@-t
- echo 'abs_top_srcdir="$(abs_top_srcdir)"' >> $@-t
- echo 'PATH="$(parted_dir)$(sep)$(pp_dir)$(sep)$$PATH"' >> $@-t
- echo 'export PATH' >> $@-t
- chmod a-w $@-t
- mv $@-t $@
-
# Note that the first lines are statements. They ensure that environment
# variables that can perturb tests are unset or set to expected values.
# The rest are envvar settings that propagate build-related Makefile