summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2011-10-12 11:18:47 +0200
committerJim Meyering <meyering@redhat.com>2011-10-15 10:15:34 +0200
commit9bfa72becb3585e7852566fdee9fc1ec8043b2ec (patch)
tree584abf44fe9f95eb7acbaf27dd42c94e26375752 /tests/Makefile.am
parent4c901abefb0b6e39d8d4b74df72f77afa7e8bb58 (diff)
downloadparted-9bfa72becb3585e7852566fdee9fc1ec8043b2ec.tar.gz
tests: use more portable fd redirection in TESTS_ENVIRONMENT
* tests/Makefile.am (TESTS_ENVIRONMENT): Redirection with `exec 9>&2' is not portable to various Korn shells, and to (at least) HP-UX 11 /bin/sh. Use a more portable idiom. See <http://thread.gmane.org/gmane.comp.gnu.coreutils.bugs/22488> for lots of discussion.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f7a170d..f70c524 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -80,7 +80,6 @@ sep = $(PATH_SEPARATOR)
TESTS_ENVIRONMENT = \
tmp__=$$TMPDIR; test -d "$$tmp__" || tmp__=.; \
TMPDIR=$$tmp__; export TMPDIR; \
- exec 9>&2; \
export \
abs_top_builddir='$(abs_top_builddir)' \
abs_top_srcdir='$(abs_top_srcdir)' \
@@ -100,6 +99,6 @@ TESTS_ENVIRONMENT = \
REPLACE_GETCWD=$(REPLACE_GETCWD) \
PATH='$(abs_top_builddir)/parted$(PATH_SEPARATOR)'"$$PATH" \
VERSION=$(VERSION) \
- ;
+ ; 9>&2
VERBOSE = yes