summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-09-29 12:10:35 +0200
committerJim Meyering <meyering@redhat.com>2012-09-29 12:35:51 +0200
commitc987c73cbe773dfa3b14b911ffc243137195bbb3 (patch)
treefdc1275361d1171ef87405dedb0f54de75d1e25b /tests/Makefile.am
parente6536360bd4496cee1f1bf2dfb0b11f6bdbbfd4b (diff)
downloadparted-c987c73cbe773dfa3b14b911ffc243137195bbb3.tar.gz
tests: clean up tests
Use warn_ and $ME_ in place of warn and $ME; remove definitions of the latter two. Remove unused code. * tests/lvm-utils.sh: Remove file. All functions were either unused or duplicated/better in t-lvm.sh. * tests/Makefile.am (EXTRA_DIST): Remove it. * tests/t-local.sh (scsi_debug_setup_): Use echo 1>&2, not warn_, to emit to log file only, not console. The diagnostic it emitted (in verbose mode) was more "informational" than a warning. * tests/t9030-align-check.sh: Use warn_, not warn. * tests/t-lvm.sh: Likewise, and use fail_, not error (undefined!). * tests/t-lib-helpers.sh (device_mapper_required_): Use t-lvm.sh and an explicit lvm_init_root_dir_ in place of lvm-utils.sh.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 96abecb..80d5525 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -74,7 +74,7 @@ TESTS = \
t9050-partition-table-types.sh
EXTRA_DIST = \
- $(TESTS) lvm-utils.sh t-local.sh t-lvm.sh \
+ $(TESTS) t-local.sh t-lvm.sh \
init.cfg init.sh t-lib-helpers.sh gpt-header-munge
check_PROGRAMS = print-align print-max dup-clobber duplicate fs-resize