summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-01-13 18:33:18 +0100
committerJim Meyering <meyering@redhat.com>2012-02-10 20:05:50 +0100
commitd9c1e1a5686943db044e6f24cae7d09a5a9e095c (patch)
tree17f77601652144da4ab98885574b9614a4000a85 /tests/Makefile.am
parent5bfc7fd8e38da8bee87abf323e68f8be5937e728 (diff)
downloadparted-d9c1e1a5686943db044e6f24cae7d09a5a9e095c.tar.gz
tests: test FAT and HFS file system resizing
* tests/t3000-resize-fs.sh: New test. * tests/Makefile.am (TESTS): Add it. (check_PROGRAMS): Add fs-resize. (fs_resize_LDADD): Define, so it links with both libraries.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 917ebe7..1b37fd9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -40,6 +40,7 @@ TESTS = \
t2310-dos-extended-2-sector-min-offset.sh \
t2400-dos-hfs-partition-type.sh \
t2500-probe-corrupt-hfs.sh \
+ t3000-resize-fs.sh \
t3200-type-change.sh \
t3300-palo-prep.sh \
t3310-flags.sh \
@@ -73,7 +74,11 @@ EXTRA_DIST = \
$(TESTS) lvm-utils.sh t-local.sh t-lvm.sh \
init.cfg init.sh t-lib-helpers.sh gpt-header-munge
-check_PROGRAMS = print-align print-max dup-clobber duplicate
+check_PROGRAMS = print-align print-max dup-clobber duplicate fs-resize
+fs_resize_LDADD = \
+ $(top_builddir)/libparted/fs/libparted-fs-resize.la \
+ $(top_builddir)/libparted/libparted.la
+
LDADD = \
$(top_builddir)/libparted/libparted.la
AM_CPPFLAGS = \