summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-03-10 18:06:12 -0400
committerMonty Taylor <mordred@inaugust.com>2013-03-10 21:14:15 -0400
commit8a4789883a38aef43e558abee7c5a27f0d7cc03b (patch)
tree920e60f06a2b60021e04b6c13b5b4dcecf343233 /setup.py
parentaa4641f0e6e668d4eb3a0c1f70a3e15e83097c6a (diff)
downloadpbr-8a4789883a38aef43e558abee7c5a27f0d7cc03b.tar.gz
Fix things up to work with nova.
Add extern/six back - turns out setup_requires isn't transitive. Make sure .gitignore is right.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bbb4e9b..5cd6208 100755
--- a/setup.py
+++ b/setup.py
@@ -14,10 +14,12 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-from setuptools import setup
+import setuptools
# See setup.cfg for the project metadata.
-from oslo.setup import util import filtered_args
+from oslo.packaging import util
-setup(**filtered_args())
+# Use our internals directly, so that we don't chicken-and-egg needing to
+# install an entry point before using ourself.
+setuptools.setup(**util.filtered_args())