summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Hellmann <doug.hellmann@dreamhost.com>2012-09-28 15:55:14 -0400
committerDoug Hellmann <doug.hellmann@dreamhost.com>2012-09-28 15:55:57 -0400
commite43a70a236a47cf9ecaca8af21d62e503517b992 (patch)
tree8e43460b3c691b657623463bb5430a2aa84d44dd /setup.py
parent50da12ff8625b4f7f7493bad2e69404d61bbab87 (diff)
downloadpbr-e43a70a236a47cf9ecaca8af21d62e503517b992.tar.gz
Ignore the stackforge jenkins email address
Update generate_authors to ignore the email address for the stackforge jenkins as well as the main openstack jenkins, to ignore commits in the history of projects that were on stackforge before moving over to the main server (such as ceilometer). Change-Id: I86d93ba0f358d5d33278847ba8de039642dd54b7 Signed-off-by: Doug Hellmann <doug.hellmann@dreamhost.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 628f5e3..317e82d 100644
--- a/setup.py
+++ b/setup.py
@@ -191,14 +191,14 @@ def write_git_changelog():
def generate_authors():
"""Create AUTHORS file using git commits."""
- jenkins_email = 'jenkins@review.openstack.org'
+ jenkins_email = 'jenkins@review.(openstack|stackforge).org'
old_authors = 'AUTHORS.in'
new_authors = 'AUTHORS'
if not os.getenv('SKIP_GENERATE_AUTHORS'):
if os.path.isdir('.git'):
# don't include jenkins email address in AUTHORS file
git_log_cmd = ("git log --format='%aN <%aE>' | sort -u | "
- "grep -v " + jenkins_email)
+ "egrep -v '" + jenkins_email + "'")
changelog = _run_shell_command(git_log_cmd)
mailmap = parse_mailmap()
with open(new_authors, 'w') as new_authors_fh: