summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2009-09-01 16:29:46 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2009-09-01 16:29:46 +0000
commit1dde538aa47f1971bcc1b62c4d151e9b0ab91c39 (patch)
treee1b8460b9154a33f30ab988363445fd143d21f2b /configure.ac
parentdbbbb5f823318e1665b0ae6fb2f7c12d71f66e84 (diff)
downloadpcre-1dde538aa47f1971bcc1b62c4d151e9b0ab91c39.tar.gz
Add -DPCRE_STATIC to configuration files when no shared library is built.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@430 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b835571..a4bda76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,10 +379,13 @@ AC_CHECK_LIB([readline], [readline], [HAVE_LIB_READLINE=1])
# This facilitates -ansi builds under Linux
dnl AC_DEFINE([_GNU_SOURCE], [], [Enable GNU extensions in glibc])
+PCRE_STATIC_CFLAG=""
if test "x$enable_shared" = "xno" ; then
AC_DEFINE([PCRE_STATIC], [1], [
Define if linking statically (TODO: make nice with Libtool)])
+ PCRE_STATIC_CFLAG="-DPCRE_STATIC"
fi
+AC_SUBST(PCRE_STATIC_CFLAG)
# Here is where pcre specific defines are handled