summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2013-11-19 15:36:57 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2013-11-19 15:36:57 +0000
commit3d0a81dbf14c870df3ab19470bee0c29e1999521 (patch)
tree511475cb8f16f29d723c3fed946eb744895e2fed /configure.ac
parent840d6a79dec6e3b5c1324207043fb93dea810223 (diff)
downloadpcre-3d0a81dbf14c870df3ab19470bee0c29e1999521.tar.gz
Source tidies for 8.34-RC1.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1404 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 12 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index ecb9415..b4aa658 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,16 +10,16 @@ dnl be defined as -RC2, for example. For real releases, it should be empty.
m4_define(pcre_major, [8])
m4_define(pcre_minor, [34])
-m4_define(pcre_prerelease, [-RC])
-m4_define(pcre_date, [2013-06-14])
+m4_define(pcre_prerelease, [-RC1])
+m4_define(pcre_date, [2013-11-19])
# NOTE: The CMakeLists.txt file searches for the above variables in the first
# 50 lines of this file. Please update that if the variables above are moved.
# Libtool shared library interface versions (current:revision:age)
-m4_define(libpcre_version, [3:1:2])
-m4_define(libpcre16_version, [2:1:2])
-m4_define(libpcre32_version, [0:1:0])
+m4_define(libpcre_version, [3:2:2])
+m4_define(libpcre16_version, [2:2:2])
+m4_define(libpcre32_version, [0:2:0])
m4_define(libpcreposix_version, [0:2:0])
m4_define(libpcrecpp_version, [0:0:0])
@@ -274,12 +274,12 @@ AC_ARG_WITH(link-size,
AS_HELP_STRING([--with-link-size=N],
[internal link size (2, 3, or 4 allowed; default=2)]),
, with_link_size=2)
-
+
# Handle --with-parens-nest-limit=N
AC_ARG_WITH(parens-nest-limit,
AS_HELP_STRING([--with-parens-nest-limit=N],
[nested parentheses limit (default=250)]),
- , with_parens_nest_limit=250)
+ , with_parens_nest_limit=250)
# Handle --with-match-limit=N
AC_ARG_WITH(match-limit,
@@ -789,11 +789,11 @@ AC_DEFINE_UNQUOTED([POSIX_MALLOC_THRESHOLD], [$with_posix_malloc_threshold], [
small, the wrapper function uses space on the stack, because this is
faster than using malloc() for each call. The threshold above which
the stack is no longer used is defined by POSIX_MALLOC_THRESHOLD.])
-
+
AC_DEFINE_UNQUOTED([PARENS_NEST_LIMIT], [$with_parens_nest_limit], [
- The value of PARENS_NEST_LIMIT specifies the maximum depth of nested
- parentheses (of any kind) in a pattern. This limits the amount of system
- stack that is used while compiling a pattern.])
+ The value of PARENS_NEST_LIMIT specifies the maximum depth of nested
+ parentheses (of any kind) in a pattern. This limits the amount of system
+ stack that is used while compiling a pattern.])
AC_DEFINE_UNQUOTED([MATCH_LIMIT], [$with_match_limit], [
The value of MATCH_LIMIT determines the default number of times the
@@ -1082,7 +1082,7 @@ $PACKAGE-$VERSION configuration summary:
Use stack recursion ............. : ${enable_stack_for_recursion}
POSIX mem threshold ............. : ${with_posix_malloc_threshold}
Internal link size .............. : ${with_link_size}
- Nested parentheses limit ........ : ${with_parens_nest_limit}
+ Nested parentheses limit ........ : ${with_parens_nest_limit}
Match limit ..................... : ${with_match_limit}
Match limit recursion ........... : ${with_match_limit_recursion}
Build shared libs ............... : ${enable_shared}