summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-08-27 13:15:02 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-08-27 13:15:02 +0000
commit5be014aeca2947719ddec347eee6df2001ad1bee (patch)
treeb14b263f4e97147f3b81e14c602f3f35a5a3cc13 /configure.ac
parent68d8f7c667b7438a2d8754e0f1ca2be39f0c239a (diff)
downloadpcre-5be014aeca2947719ddec347eee6df2001ad1bee.tar.gz
Daniel Richard G's patch for checking POSIX threads when JIT is configure.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1019 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e2f4cc2..8564f3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -604,6 +604,10 @@ if test "$enable_pcre16" = "yes"; then
fi
if test "$enable_jit" = "yes"; then
+ AX_PTHREAD([], [AC_MSG_ERROR([JIT support requires pthreads])])
+ CC="$PTHREAD_CC"
+ CFLAGS="$PTHREAD_CFLAGS $CFLAGS"
+ LIBS="$PTHREAD_LIBS $LIBS"
AC_DEFINE([SUPPORT_JIT], [], [
Define to any value to enable support for Just-In-Time compiling.])
else