summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2014-01-10 16:25:55 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2014-01-10 16:25:55 +0000
commit72e25ffe7010391778433c9f5ed6a5e217e1d7c4 (patch)
tree9899cd3b588a966bb913bb4b7b206c98bba66476 /configure.ac
parent01746cfc6c30e4988c6e753f1ca0ef22e0f756d9 (diff)
downloadpcre-72e25ffe7010391778433c9f5ed6a5e217e1d7c4.tar.gz
Only test for pthreads when not under Windows.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1439 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 516936a..02992b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -686,11 +686,15 @@ if test "$enable_pcre32" = "yes"; then
Define to any value to enable the 32 bit PCRE library.])
fi
+# Unless running under Windows, JIT support requires pthreads.
+
if test "$enable_jit" = "yes"; then
- AX_PTHREAD([], [AC_MSG_ERROR([JIT support requires pthreads])])
- CC="$PTHREAD_CC"
- CFLAGS="$PTHREAD_CFLAGS $CFLAGS"
- LIBS="$PTHREAD_LIBS $LIBS"
+ if test "$HAVE_WINDOWS_H" != "1"; then
+ AX_PTHREAD([], [AC_MSG_ERROR([JIT support requires pthreads])])
+ CC="$PTHREAD_CC"
+ CFLAGS="$PTHREAD_CFLAGS $CFLAGS"
+ LIBS="$PTHREAD_LIBS $LIBS"
+ fi
AC_DEFINE([SUPPORT_JIT], [], [
Define to any value to enable support for Just-In-Time compiling.])
else