summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-02-26 16:08:15 +0000
committerph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>2012-02-26 16:08:15 +0000
commit94e0ffce6a828fb3fc8c77364f34230434b127ea (patch)
treef6c3ed48236377c424615691be3ce243f0ac623d /configure.ac
parent22ff165865c39cc160b4341664b053707ebfa5e9 (diff)
downloadpcre-94e0ffce6a828fb3fc8c77364f34230434b127ea.tar.gz
Add /usr/include/edit/readline/ as somewhere where editline's header might be.
git-svn-id: svn://vcs.exim.org/pcre/code/trunk@938 2f5784b3-3f2a-0410-8824-cb99058d5e15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 81c6498..fd89d5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -570,11 +570,13 @@ if test "$enable_pcretest_libreadline" = "yes"; then
fi
-# Check for the availability of libedit
+# Check for the availability of libedit. Different distributions put its
+# headers in different places. Try to cover the most common ones.
if test "$enable_pcretest_libedit" = "yes"; then
AC_CHECK_HEADERS([editline/readline.h], [HAVE_EDITLINE_READLINE_H=1],
- [AC_CHECK_HEADERS([readline/readline.h], [HAVE_READLINE_READLINE_H=1])])
+ [AC_CHECK_HEADERS([edit/readline/readline.h], [HAVE_READLINE_READLINE_H=1],
+ [AC_CHECK_HEADERS([readline/readline.h], [HAVE_READLINE_READLINE_H=1])])])
AC_CHECK_LIB([edit], [readline], [LIBEDIT="-ledit"])
fi