summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2020-05-09 15:47:41 +0000
committerph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2020-05-09 15:47:41 +0000
commit858e5ac388c3d623f2ab0c62a881b98a0ecd40a7 (patch)
treeeafc2e4dcbe1b52a48780f49f311d819b9d35b41 /CMakeLists.txt
parentfee74f6d6852849aec99108caa3440da45880621 (diff)
downloadpcre2-858e5ac388c3d623f2ab0c62a881b98a0ecd40a7.tar.gz
Final file tidies for 10.35.
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@1254 6239d852-aaf2-0410-a92c-79f79f948069
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e9da6b..86b8896 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,8 +203,8 @@ SET(PCRE2_SUPPORT_JIT OFF CACHE BOOL
IF(${CMAKE_SYSTEM_NAME} MATCHES Linux|NetBSD)
SET(PCRE2_SUPPORT_JIT_SEALLOC OFF CACHE BOOL
"Enable SELinux compatible execmem allocator in JIT (experimental).")
-ELSE(${CMAKE_SYSTEM_NAME} MATCHES Linux|NetBSD)
- SET(PCRE2_SUPPORT_JIT_SEALLOC IGNORE)
+ELSE(${CMAKE_SYSTEM_NAME} MATCHES Linux|NetBSD)
+ SET(PCRE2_SUPPORT_JIT_SEALLOC IGNORE)
ENDIF(${CMAKE_SYSTEM_NAME} MATCHES Linux|NetBSD)
SET(PCRE2GREP_SUPPORT_JIT ON CACHE BOOL
@@ -332,10 +332,10 @@ ENDIF(PCRE2_SUPPORT_JIT)
IF(PCRE2_SUPPORT_JIT_SEALLOC)
SET(CMAKE_REQUIRED_DEFINITIONS -D_GNU_SOURCE)
- CHECK_SYMBOL_EXISTS(mkostemp stdlib.h REQUIRED)
+ CHECK_SYMBOL_EXISTS(mkostemp stdlib.h REQUIRED)
UNSET(CMAKE_REQUIRED_DEFINITIONS)
IF(${REQUIRED})
- IF(${CMAKE_SYSTEM_NAME} MATCHES Linux|NetBSD)
+ IF(${CMAKE_SYSTEM_NAME} MATCHES Linux|NetBSD)
ADD_DEFINITIONS(-D_GNU_SOURCE)
SET(SLJIT_PROT_EXECUTABLE_ALLOCATOR 1)
ELSE(${CMAKE_SYSTEM_NAME} MATCHES Linux|NetBSD)