summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2016-10-31 17:19:00 +0000
committerph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2016-10-31 17:19:00 +0000
commitddcf348e18aae1f8f2192658918ffef7a242d0be (patch)
treeb28f0ba2bd565ae19d4fc9de538485e2e78903dd /Makefile.am
parentbc8fccf489fbc0c4222d5c5e10a2f494c8dcffea (diff)
downloadpcre2-ddcf348e18aae1f8f2192658918ffef7a242d0be.tar.gz
Add fuzzer support features.
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@582 6239d852-aaf2-0410-a92c-79f79f948069
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 951d844..6386f81 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,6 @@
AUTOMAKE_OPTIONS = subdir-objects
ACLOCAL_AMFLAGS = -I m4
-AM_CPPFLAGS = -I$(builddir)/src -I$(srcdir)/src
## Specify the documentation files that are distributed.
@@ -473,7 +472,7 @@ libpcre2_posix_la_CFLAGS += $(GCOV_CFLAGS)
endif # WITH_GCOV
endif # WITH_PCRE2_8
-## Build pcre2grep if the 8-bit library is enabled
+## Build pcre2grep and optional fuzzer stuff if the 8-bit library is enabled
if WITH_PCRE2_8
bin_PROGRAMS += pcre2grep
@@ -485,6 +484,22 @@ if WITH_GCOV
pcre2grep_CFLAGS += $(GCOV_CFLAGS)
pcre2grep_LDADD += $(GCOV_LIBS)
endif # WITH_GCOV
+
+## If fuzzer support is enabled, build a non-distributed library containing the
+## fuzzing function. Also build the standalone checking binary from the same
+## source but using -DSTANDALONE.
+
+if WITH_FUZZ_SUPPORT
+noinst_LIBRARIES = .libs/libpcre2-fuzzsupport.a
+_libs_libpcre2_fuzzsupport_a_SOURCES = src/pcre2_fuzzsupport.c
+_libs_libpcre2_fuzzsupport_a_CFLAGS = $(AM_CFLAGS)
+_libs_libpcre2_fuzzsupport_a_LIBADD =
+
+noinst_PROGRAMS += pcre2fuzzcheck
+pcre2fuzzcheck_SOURCES = src/pcre2_fuzzsupport.c
+pcre2fuzzcheck_CFLAGS = -DSTANDALONE $(AM_CFLAGS)
+pcre2fuzzcheck_LDADD = libpcre2-8.la
+endif # WITH FUZZ_SUPPORT
endif # WITH_PCRE2_8
## -------- Testing ----------